Pip

De Goffiwiki
Aller à : navigation, rechercher

L'installation de SaT requiert gcc/g++ (fourni par le paquet build-essential sous Debian)

L'installation avec pip aboutit à:

    no previously-included directories found matching 'src/bridge/bridge_constructor/generated'
Requirement already satisfied (use --upgrade to upgrade): twisted in /usr/local/lib/python2.7/dist-packages (from sat==0.2.0)
Requirement already satisfied (use --upgrade to upgrade): progressbar in /usr/local/lib/python2.7/dist-packages/progressbar-2.3-py2.7.egg (from sat==0.2.0)
Requirement already satisfied (use --upgrade to upgrade): urwid in /usr/lib/python2.7/dist-packages (from sat==0.2.0)
Requirement already satisfied (use --upgrade to upgrade): beautifulsoup in /usr/local/lib/python2.7/dist-packages/BeautifulSoup-3.2.0-py2.7.egg (from sat==0.2.0)
Requirement already satisfied (use --upgrade to upgrade): mercurial in /usr/local/lib/python2.7/dist-packages (from sat==0.2.0)
Downloading/unpacking urwid-satext (from sat==0.2.0)
  Running setup.py egg_info for package urwid-satext
    
Downloading/unpacking pyfeed (from sat==0.2.0)
  Running setup.py egg_info for package pyfeed
    
Downloading/unpacking xe (from sat==0.2.0)
  Running setup.py egg_info for package xe
    
Downloading/unpacking zope.interface (from twisted->sat==0.2.0)
  Running setup.py egg_info for package zope.interface
    
Requirement already satisfied (use --upgrade to upgrade): distribute in /usr/lib/python2.7/dist-packages (from zope.interface->twisted->sat==0.2.0)
Installing collected packages: urwid-satext, pyfeed, xe, sat, zope.interface
  Running setup.py install for urwid-satext
    error: can't copy 'CHANGELOG': doesn't exist or not a regular file
    Complete output from command /usr/bin/python -c "import setuptools;__file__='/home/mmmchaude/build/urwid-satext/setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --single-version-externally-managed --record /tmp/pip-bUIl5K-record/install-record.txt:
    running install

running build

running build_py

running install_lib

running install_data

error: can't copy 'CHANGELOG': doesn't exist or not a regular file

----------------------------------------
Command /usr/bin/python -c "import setuptools;__file__='/home/mmmchaude/build/urwid-satext/setup.py';exec(compile(open(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --single-version-externally-managed --record /tmp/pip-bUIl5K-record/install-record.txt failed with error code 1
Storing complete log in /root/.pip/pip.log


  • Effectivement, créer un fichier CHANGELOG dans ./build/urwid-satext/ règle le problème.
touch ./build/urwid-satext/CHANGELOG

(En attendant que le dépot Mercurial soit mis à jour)